Zsh Mailing List Archive
Messages sorted by: Reverse Date, Date, Thread, Author

Re: Moving completion functions

Sven wrote:

> - I was wondering if _mere is for the function or for some command I
>   don't know...

I assumed it was for the function and judging by the ChangeLog it must be
because in the first mention of _mere it is commited with mere.

> - _mysql_utils should probably keep it's name. I think this was
>   modelled after _psutils and _xutils. Those two should then be
>   renamed to _ps_utils and _x_utils.

I'm not sure that it should be _ps_utils because the psutils is a single
package of utilities distributed together which has always been called psutils
in one word. _ps_utils might imply that some other unrelated PostScript utility
should go in there also. Keeping it _mysql_utils and renaming to _x_utils is
fine though.

> - _use_lo should get a better name, yes. Hm, I don't like mixing the
>   underscore-style we use with hyphens in function names, and anyway I
>   prefer _parse_help (or _options_from__help?)

My main reservation about _parse_help is that the function doesn't do the
actual parsing itself, it gets _arguments to do it. That aside, it looks and
sounds better than _options_from__help.

> - We could also change _call to _call_program and _funcall to
>   _call_function.

That seems good. The documentation for _call talks about calling a 'command' so
maybe it should be _call_command but program might be clearer.

> - And there could be a better name for _compalso.

I agree but I can't think of anything better.

> - For the label functions (and the tag functions) I think we should
>   either leave them or try to find names that are both readable and
>   have the sorting behaviour Bart wants (and not only he, I like that, 
>   too). So...
>     _tags        _tags
>     _wanted      _tag_wanted
>     _requested   _tag_requested or _tag_selected
>     _all_labels  _labels_for
>     _next_label  _label_selected

I like the sorting behaviour too but am not particularly convinced by these.
_tag_requested just seems quite long for something which is used a lot. One
option is removing the 'ed' so we just have _tag_want and _tag_request.

Another option which I think I prefer would be to use something like _want_now
or _wanted_now for _requested which groups it with _wanted while possibly
better expressing the difference with _wanted which you were getting at with
the _tag_selected idea.

I'm not sure about the labels. Anyway, I'm being dragged down the pub so I'll
have to finish this reply next week.


This message has been checked for all known viruses by the 
MessageLabs Virus Control Centre. For further information visit

Messages sorted by: Reverse Date, Date, Thread, Author