Zsh Mailing List Archive
Messages sorted by: Reverse Date, Date, Thread, Author

Re: zsh coding standards

Wayne Davison wrote:
> Speaking of coding standards, it has only been fairly recently (perhaps
> this year?) that you have started to put braces on the line following an
> "if", "while", etc.  Is this a conscious decision to change zsh's coding
> style?  I personally prefer seeing the braces on the same line as the
> controlling statement (except for the start of a function).

It's because that's how we do it at CSR, and switching between the two
is too complicated for me.  It's not intentional.

> Use "{}" on an empty loop instead of ";" to make it more obvious that no
> looping statements follow.

I think this is mostly done by putting the ";" on the next line, which
makes the intention clear enough.  Putting a ";" on the same line
immediately after the loop statement is certainly more bug-prone.

> Attached is a patch of the zchdir() function that contains only the style
> changes mentioned above.  They won't be committed unless agreement is
> reached that they would be a good thing.

Anything that makes it more readable is fine by me, although it's quite
hard to enforce this sort of nicety.

Peter Stephenson <pws@xxxxxxx>                  Software Engineer
CSR PLC, Churchill House, Cambridge Business Park, Cowley Road
Cambridge, CB4 0WZ, UK                          Tel: +44 (0)1223 692070

This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

This footnote also confirms that this email message has been swept by
MIMEsweeper for the presence of computer viruses.


Messages sorted by: Reverse Date, Date, Thread, Author