Zsh Mailing List Archive
Messages sorted by: Reverse Date, Date, Thread, Author

Re: [PATCH] Add API wrapper to ${+_comps[...]}

On Oct 5,  9:51pm, Daniel Shahaf wrote:
} Subject: Re: [PATCH] Add API wrapper to ${+_comps[...]}
} Bart Schaefer wrote on Sat, Oct 03, 2015 at 17:49:19 -0700:
} > 
} > (Why two separate patches both to compsys.yo?)
} One logical change per commit.

But you don't care about one logical commit per zsh-workers sequence
number?  I mean, I'm not unreasonably sticky about it, but I try to
keep it that way.

} > On the other hand there are tests for whether a particular function
} > is defined.  If that function is destined to be assigned to _comps[x]
} > perhaps it would be better to check for _comps[x] already defined
} > instead.
} _comps[x] being already defined in what sense?  I can think of three
} meanings: (a) hash key exists

That sense.

The point being that if we're going to bother defining "compexists"
then maybe we ought to use it instead of (( ${+functions[_name]} )).
It couldn't replace all such tests, since in most cases those are
"helper" functions rather than values in $_comps, but perhaps some.

I'm trying to find a metric for usefulness.

Messages sorted by: Reverse Date, Date, Thread, Author