Zsh Mailing List Archive
Messages sorted by:
Re: [PATCH] declarednull: rename DECLARED to NULL
- X-seq: zsh-workers 48299
- From: Oliver Kiddle <opk@xxxxxxx>
- To: Bart Schaefer <schaefer@xxxxxxxxxxxxxxxx>
- Cc: Zsh hackers list <zsh-workers@xxxxxxx>
- Subject: Re: [PATCH] declarednull: rename DECLARED to NULL
- Date: Mon, 29 Mar 2021 02:44:38 +0200
- Archived-at: <https://zsh.org/workers/48299>
- Archived-at: <http://www.zsh.org/sympa/arcsearch_id/zsh-workers/2021-03/83994-1616978678.232193%40jPMH.zQZs.0I47>
- In-reply-to: <CAH+w=7ZQhoS8dfN+y_O712wXYCW1kWN_TDT14AqZ07AubM2email@example.com>
- List-id: <zsh-workers.zsh.org>
- References: <firstname.lastname@example.org> <CAH+w=7aHddgDB9jbKoL2pceNwPM48pF6+V3oiHzd8versYVW7w@mail.gmail.com> <CAMP44s2v4dJJe8XhGfzzvsANMiT25COreKEhuqF3VgEfqSZ4Fg@mail.gmail.com> <CAH+w=7ZL0KGcd8b4mmRhMSPuX-bEgMZi5XG7G37vLo1m87GUAg@mail.gmail.com> <20210104061718.GB14783@tarpaulin.shahaf.local2> <CAH+w=7ZX8ddgLH3DdsrCg6pgxY8KbRo1nqF5qLxZ2HL0JtcWNw@mail.gmail.com> <email@example.com> <CAH+w=7a5xzztvJ9hRB-2-LyzyZFx74Pfy5z8cJu01=hOh_AHQw@mail.gmail.com> <firstname.lastname@example.org> <CAH+w=7ZQhoS8dfN+y_O712wXYCW1kWN_TDT14AqZ07AubM2email@example.com>
Bart Schaefer wrote:
> Since we resolved this down to arguing about internal names that are
> never visible to the user, IMO the primary remaining question is
> whether it's acceptable to make the user-visible behavior dependent on
> the POSIX_BUILTINS option.
It seems fairly self-contained and could have it's own option. typeset
isn't a builtin. posix compatibility options aren't really improvements
but someone might prefer this behaviour. But I don't have a strong
view - whatever you think is good.
> Perhaps the internal naming argument can be resolved by using
> PM_DEFAULTED (thus making it definitely a verb rather than "default"
> which could be interpreted as a noun).
I'm fine with that but I wouldn't especially object to DECLARED or
whatever it was before. Some other ideas:
ONLYDECLARED, DECLONLY, UNASSIGNED, INITIATED, CONCEIVED, SCOPED.
Was there anything else outstanding like (t) output perhaps?
I don't feel strongly about either of these naming issues and would be
happy for this to move forward regardless of the outcome on them.
Messages sorted by: