Zsh Mailing List Archive
Messages sorted by: Reverse Date, Date, Thread, Author

Re: Moving completion functions

On Mar 28,  4:12pm, Sven Wischnowsky wrote:
} I really only have a suggestion for _compalso: putting it into
} Base/Utility and renaming it to `_contexts' because it completes
} everything for the context described in the arguments, just like
} _arguments and other functions in Utility.

That sounds like a fine idea to me.

} And a better name for `_wanted' might be `_offer', but that doesn't
} make it easier to find in a directory listing, of course.  Although it
} would end up just before `_requested' and there are only twelve
} functions in the directory anyway.

That one is a toss-up.  I don't know whether _offer is better than _wanted.
The number of functions in the directory isn't an issue.

} Twelve, unless we move the _call_* function into the Utility directory,
} too, which seems sensible, somehow.

Yes, that does seem sensible.

BTW, a remark on my sectioning scheme for the Test directory:  Section Y
is for tests of builtin interactive commands/constructs (select, read -q,
etc.) where the tests themselves need to use the zpty module, which will
(eventually) have been tested in section X ...

We might want to add description of this naming to a Test/README or to the
comments in ztst.zsh.

Bart Schaefer                                 Brass Lantern Enterprises
http://www.well.com/user/barts              http://www.brasslantern.com

Zsh: http://www.zsh.org | PHPerl Project: http://phperl.sourceforge.net   

Messages sorted by: Reverse Date, Date, Thread, Author